Call For Mac & Linux Developers

It’s been a little while now from the change-over from Jacek to myself (ZATZAi) and I’m finally starting to get a handle on things. I have some projects I’m working on with the others here on the team to try and make your Imprudence experience better in the future. Here on the web site front the plan is to better integrate the wiki, the forum and the blog to provide a more seamless experience and to make it easy to everyone to find what they’re looking for. Whether you’re looking for where to report a bug or how to do it, where to give feedback, or how to get support… The plan is to make the site and it’s features more straight forward and accessible to users who need more information or want to communicate but don’t know what the proper channels are.

On the client front, we’ve recently released Imprudence 1.4 Beta 2 which fixed a great deal of bugs from the first beta and we continue to work on the next release (No timeline yet, but I’ll try to post something as we get closer). On that front we could use some help. If you have programming experience with C++ and the Mac or Linux 32bit platforms and would like to volunteer please get in touch with us. We’re of course interested in anyone who wants to volunteer, but we’re in particular need of developers for those two platforms. So if you have a passion for Virtual Worlds, C++ experience and can compile the client on Mac and/or Linux 32bit and would like to help develop the future of Imprudence/Kokua, then by all means drop us a lines.

Please send inquiries to me directly for now, I’ll set up a form on this blog to make it easier in the future.

zatzai (a) kokuaviewer.org

8 Responses to “Call For Mac & Linux Developers”


  1. Baloo Uriza

    There will still be 64-bit Linux binaries, right?

  2. ZATZAi

    We have a 64bit Linux Dev currently (Who has been helping with 32bit when they can), but need someone who regularly works with 32bit Linux.

  3. Paolo

    linux 32bit is… obsolete! ;)

    imprudence is the only SL client compiled also for amd64 platform. (and i use imprudence for this reason)

    Drop 32bit linux! you’ll make history! :-)

  4. onefang

    Actually, I did a survey amongst users on a grid I used to work for as a viewer developer. The point of the survey was to sort out what Linux platforms I should create viewer releases for. The result on that grid was – 32 AND 64 bit versions for Ubuntu 10.04 would cover the majority. I even had 64 bit Linux users saying they would prefer if I made 32 bit versions. It was split about 50/50 between 32 and 64 bit.

    Since then, my 32 bit system died during a lightning storm. I still make 32 bit versions, built under a virtual 32 bit Ubuntu 10.04 Linux install.

    So 32 bit Linux is not dead, just my 32 bit Linux development box. lol

    I think Imprudence made history by doing good 64 bit support in the first place. They still have to support 32 bit on OTHER platforms though.

  5. Bob Shaffer

    Is this a paying job, or are you just looking for volunteers to work on your 32 bit linux/mac clients? And other than knowing C++ and being able to compile the 32 bit client, what other qualifications are you looking for?

  6. onefang

    Um, this will be the third time I have offered to help. Admittedly the last two might have gotten lost when Jacek left.

    In case it was not obvious from my previous post, yes I can do 64 bit and 32 bit linux Imprudence packages, and I’m willing to help. I even have nice, easy to use build scripts that have been called “the easiest way to compile a viewer under linux”. I think there is an ancient issue in the tracker about those. I’ll probably submit them later.

    However, I had submitted patches earlier, which had been marked “ready to merge” months ago. Those patches even came up in a dev meeting long ago as “should merge onefang’s patches” or words to that effect. From my point of view, they were test patches, to see how the process of submitting patches to your project works out. I’m waiting to see the results before submitting more, so I know how best to do that. A long wait so far, they are still not merged. lol

    One big thing that my fellow developers and I just missed the feature freeze for 1.40, that Impy devs mentioned a desire for, and that we could supply, is OTR support. I notice that a new feature for external script editing got in recently. Um, is the feature freeze suspended, even though you are still in beta? Should I submit OTR patches now? Oh wait, I have to wait for my last patches to get in to make sure I’ve followed your patch procedure correctly. B-)

  7. Tekno Mekanik

    I’m not a dev, sorry But I am a user and huge fan of this work. I hope that this really takes off and we see some awesome work for the linux users out there. I run chakra 64 and hope to just see this get better and better. Cheers to all those that do work on this and know I for one really appreciate what you guys/girls are doing.

  8. onefang

    Bob, Imprudence is not a company, it’s a volunteer group. So it’s not a paying job. I’m guessing that a familiarity with the internals of viewer source code, and Imprudence/Kokua in particular, would be needed.