New 1.3.1 package for Linux32

Many 32-bit Linux users have been experiencing an error message when attempting to run Imprudence 1.3.1:

bin/do-not-directly-run-imprudence-bin: error while loading shared libraries: libz.so: cannot open shared object file: No such file or directory

This error is caused by a missing symbolic link in the “lib” directory. You can solve it one of two ways:

  • If you are comfortable using a terminal window, run these commands from inside the Imprudence directory:
    cd ./lib
    ln -s libz.so.1 libz.so
  • Or, download this new package: Imprudence-1.3.1b-Linux-x86.tar.bz2.

The only difference between the old 1.3.1 package and this one is the new symbolic link. If you are not experiencing that error message, there is no need to create the symlink or download the new package.

5 Responses to “New 1.3.1 package for Linux32”


  1. Ci Sense

    Thanks for the fix; finally imp works for me under Ubuntu.

  2. fabrixx beck

    with the minimap i can not distinguish the boundaries of individual land (1.4 experimental) is a bug?
    Thanks

  3. fabrixx beck

    sorry, with map i not distuinguish borders (not minimap)

  4. Codie

    fabbrixx: yes it’s a bug related to the Aurora flexible sim size patch, I believe. it’s fixed in the next release according to the commit list.

  5. Fabrixx Beck

    Thanks i see you have fixed.

    I’m downloading latest release :)